HEM - sharing DB over networking

    • Tibovw
      Tibovw
      Bronze
      Joined: 02.05.2010 Posts: 1,994
      I've been messing with my HEM for a while now. Had to reinstall a few times because I broke it .. :P

      What i'm basicly trying to do is make my HEM DB on my main pc , grant acces to my HEM on my laptop.

      I have to alter some files on my main pc's postgres files , to grant my laptops ip acces to the databases over network. Basicly this is were it goes wrong. My postgres fails on me after I done so.

      Now I was hoping that some sort of networking wizkid would come to my aid :)

      I'd be very grateful

      Tibo
  • 5 replies
    • netsrak
      netsrak
      Gold
      Joined: 11.03.2006 Posts: 36,838
      Did you check our FAQ? http://faq.holdemmanager.com/questions/90/Run+PostgreSQL+Over+a+Network+
    • Tibovw
      Tibovw
      Bronze
      Joined: 02.05.2010 Posts: 1,994
      Hello ! thx for your reply.

      Unfortunatly, I have been over your FAQ more than once. It just doesn't want to work for me. From the moment i alter the hba.cfg and restart the service it won't work anymore. The service doesn't start again. I tried restarting it manually in the windows process thingie but that won't work eighter. Then i can't login to my pg_admin DB anymore eighter and the only solution is to uninstall completly and reinstall.



      Tibo
    • netsrak
      netsrak
      Gold
      Joined: 11.03.2006 Posts: 36,838
      Please post your edited pg_hba.conf file, i guess you are doing something wrong.
      But changing back to the original file should repair the start problem in every case.
      It may be necessary to delete the hidden file postmaster.pid before you try the restart.
    • Tibovw
      Tibovw
      Bronze
      Joined: 02.05.2010 Posts: 1,994
      I have just started trying to get it working again for the first time in a while. Literraly 5 mins later my HEM is broke and I can't get it going anymore.

      I'll reinstall in a minute but i'll try to make clear what the problem is with some screenshots. I'm having all sorts of error messages.

      This is all just on my main pc trying to alter the settings. I haven't even tried to look at the error screens on my laptop yet. :rolleyes:





      Somehow the file resets itself alot. It only works once in a while when i change it that it actually stays that way.






      Maybe you can add me on skype and we can work out what the problem is?

      Urs sincerily,

      Tibovw
    • netsrak
      netsrak
      Gold
      Joined: 11.03.2006 Posts: 36,838
      I recommend you use a texteditor like notepad to edit the pg_hba.conf file directly as i think the pgadmin interface is a little bit buggy.

      Stop the postgresql service, create a backup copy of your pg_hba.conf file. Add a line with the ip adress you like to add to the pg_hba.conf file and save it. Restart the service and try again.

      For further help the best is if you mail me on netsrak@holdemmanager.net. Please add a link to this thread, an explanation, your pg_hba.conf file and the ip adresses of your postgresql server pc and the pc you are trying to add.