Elephant 0.96 keeps losing DB settings

    • Wurble
      Wurble
      Silver
      Joined: 04.04.2009 Posts: 456
      Please help, on startup Elephant keeps saying not connected to database, please check settings. Settings window shows and if I click ok it then creates a new database again. This is the second time I've installed because it did the same the day before yesterday but when it recreated the database it had loads of errors when importing hands and didn't show correct figures.

      Also, when running the hud stats reset to 0 hands for some or all players on some tables.

      I understand and appreciate the work that goes into creating and maintaining the software but it's getting a little annoying now. Please help..
  • 9 replies
    • mrk1988
      mrk1988
      Bronze
      Joined: 04.02.2007 Posts: 13,337
      Hey Wurble,

      sounds like something is messed up regarding postgreSQL or your databases.

      Have you tried removing all existing databases from within the elephant and create a completly fresh one?

      Also, which kind of hands are you importing that lead to the mentioned errors?
    • stanisluv
      stanisluv
      Moderator
      Moderator
      Joined: 18.06.2008 Posts: 45,038
      Do you have any anti-virus software installed on your PC?
    • Wurble
      Wurble
      Silver
      Joined: 04.04.2009 Posts: 456
      Originally posted by mrk1988
      Hey Wurble,

      sounds like something is messed up regarding postgreSQL or your databases.

      Have you tried removing all existing databases from within the elephant and create a completly fresh one?

      Also, which kind of hands are you importing that lead to the mentioned errors?
      Hi mrk,

      Yeah a couple of days ago when it last did this I completely removed elephant and postgresql from the pc and started again. The hands being imported are pokerstars, some party poker and some everest but mostly stars. It'll say like 399 files to import and 133 errors or something (can't remember exactly). I've only got about 12k hands on stars that I want tracked from the beginning of this year..

      Thanks
    • Wurble
      Wurble
      Silver
      Joined: 04.04.2009 Posts: 456
      Originally posted by stanisluv
      Do you have any anti-virus software installed on your PC?
      Hi stanisluv,

      I have the free version of AVG - you think this could be causing it?

      Thanks
    • mrk1988
      mrk1988
      Bronze
      Joined: 04.02.2007 Posts: 13,337
      Hey Wurble,

      yeah, but which hands are causing the errors?

      CashGame? Tourney? Which site?
    • stanisluv
      stanisluv
      Moderator
      Moderator
      Joined: 18.06.2008 Posts: 45,038
      Originally posted by Wurble

      Hi stanisluv,

      I have the free version of AVG - you think this could be causing it?

      Thanks
      If you use AVG Internet Security 2011 then this is because Firewall may blocks Elephants or PostgreSQL.
    • Wurble
      Wurble
      Silver
      Joined: 04.04.2009 Posts: 456
      Sorry mrk, I didn't notice. I'll re-install and get more info next time.
    • JARibeiro
      JARibeiro
      Bronze
      Joined: 18.08.2009 Posts: 3
      I have the same problem.
      Sometimes when I start Elephant it says that it cannot connect to database. There is not stats, no hands, no HUD.

      Another times, I am playing with elephant working and suddenly it says that there is an error and elephant stops HUD and hands desappear from elephant.

      I have Bit Defender Total Security 2011.
    • mrk1988
      mrk1988
      Bronze
      Joined: 04.02.2007 Posts: 13,337
      This could possibly be caused because the postgreSQL service is not running correctly. Please make sure this service is running every time you start up the elephant.