Elephant is acting really really strange.

    • fakethat
      Joined: 13.06.2011 Posts: 221
      So I'm for the first time really actually reviewing an entire session through elephant and trying to make notes.

      But suddenly (I don't know if this has got to do with making notes and using elephant more extensively) elephant freezes like every second. My mouse disappearing and only showing outside the elephant screen (in the start menu etc it does show and I can still click inside other programms). I can still alt-tab to other programms but alt tabbing back to elephant doesn't work. I can't minimalize the window (wich is always pretty much a test from me... to see in what way the programm is crashing on me). My overview pop up doesn't show when I hover over the symbol in the tray menu on the bottom right.

      Then when I leave it alone it sometimes comes back to life again. It does everytime. But then often I can just continue and then it freezes 1 minute after that. Or it comes back to life but then while reviewing (section "hands") and clicking my hand it says "session can not be evaluated". Then if I try to press some other buttons and for example click on the tab "overview" it suddenly comes up with a pop up "first, please create a new database blablabla... Then enter the username and password by you and press 'OK'." And then I need to make a new database.

      Now this is the 2nd time out of like 8 consecutive crashes in half an hour or something like that that it actually wants me to create a new database. But the first time, afterwards I could still get back to my old database after closing elephant and starting it up again. I had to switch to the original database in database management but then my hands showed again with all my notes I had made. But as I said. Then I want to continue and suddenly it crashes like 1 or 2 minutes later again. And now after 2 crashes AGAIN it says to create a new database.

      So this ain't working. But anyway, maybe it is caused by a pretty large windows update recently (I think it was yesterday). I've been having a lot of updates suddenly the last days and my PC was configuring an update today as well.

      Obviously I'm going to stop trying now to evaluate my session through elephant. I'll edit this post and give you information on if it will act funny as well if I just let it track hands while I'm playing. Because so far it hasn't caused any problems while playing. The daily overview pop up always shows. And sometimes I copy a hand to the clipboard or save a graph to show on the forum but I haven't reviewed a session as extensively as I have so today. So maybe it only crashes when used extensively? I'll keep you updated.

      PS. While trying to get to my database now again it is now stuck. I tried to exit the programm this time instead of immediatly making a new database. I canceled the action, closed elephant. And now this message pops up again at the START of the programm. And now I can't even get it. If I create a new database and type a password similar to the one I made in the first error (the password was already filled in the first time it asked to create a new database) it now starts processing and then says "database doesn't need to be created because it already exists" or something like that. But instead of starting up then it says again that I need to create a new database.

      I'm just going to quit now. Maybe if I use a different name it will work. But this is just horrible. Getting sick of it.

      Edit: so I guess you can forget about me updating if the tracking works (and showing the daily overview pop up in the bottom right). As I'm not even bothered to try and figure out how I can get the programm to start again (different database name, different password, etc).
  • 3 replies
    • shane0878
      Joined: 30.06.2009 Posts: 164
      I find Elephant is an absolute hog if you have a large amount of hands in your database.
      Check your filters so you're only looking at the hands you want.
      I filter by day and limit.
    • fakethat
      Joined: 13.06.2011 Posts: 221
      Ok so I'm back into the program again.

      Did the exact same thing (creating the database) then it said it wasn't necessary again like it did earlier. But then it suddenly opened instead of asking me to make a new database AGAIN and just keep spinning in circles.

      My history is still there. HUD is working. So it's all good again. But it's terrible. Won't go review my session anymore.

      Because it will probably crash for like the 20th time today again.
    • mrk1988
      Joined: 04.02.2007 Posts: 13,337
      Hey fakethat,

      looks like you are loosing your connection to the postgreSQL database service during heavy database access (reviewing hands, taking notes, etc..).

      Have a look at the windows event viewer in your control panel. Look out for entries made by postgreSQL.

      So... everything is working fine, except you are experiencing crashes during session reviews!?

      Please post the latest logfile to this thread. There's a good chance that we will be able to identify the problem.