Problem with depositing

    • Marian21x
      Marian21x
      Silver
      Joined: 20.01.2010 Posts: 36
      Hello,

      I have problems with my deposit on Everest. When I open poker account window, I select moneybookers as my preferred option, fill the deposit amount and than press continue, it goes gray the whole window with refreshing icon in the middle but nothing happens. Could you help me, what should I do?
      Thank you

      Marian
  • 5 replies
    • IngridN
      IngridN
      Bronze
      Joined: 02.03.2011 Posts: 12,162
      Hi Marian,

      I have a stupid question, do you have funds on your Moneybookers balance? :)

      You may use the following methods to deposit funds into your Everest player account:

      Credit/Debit Cards (Visa and MasterCard)
      NETELLER
      Moneybookers
      Entropay
      Click2Pay
      Paysafecard

      Note that the availability of certain payment methods may vary by region.

      Best would be if you could send an email to Everest poker support and ask for further help. You can also upload a screen shot here so we can see what's really the problem.

      Ingrid
    • Marian21x
      Marian21x
      Silver
      Joined: 20.01.2010 Posts: 36
      Hello Ingrid,

      Originally posted by IngridN
      I have a stupid question, do you have funds on your Moneybookers balance? :)
      Yes, I have, I moved my roll from another room to my moneybookers acc. ;)

      Here is pic:


      Uploaded with ImageShack.us
      And this is how it stay and nothing else happens. Just this screen.

      I wrote an email to Everest as well, no reply till now. So I thought I would ask here, If someone else having same problem.

      Thanks anyway.

      Marian
    • Marian21x
      Marian21x
      Silver
      Joined: 20.01.2010 Posts: 36
      Could it be in Ineternetexplorer? Shouldnt I change some security settings, cookies or I dont know what?
    • Holdemfreakie
      Holdemfreakie
      Bronze
      Joined: 26.05.2011 Posts: 133
      Originally posted by Marian21x
      Could it be in Ineternetexplorer? Shouldnt I change some security settings, cookies or I dont know what?
      you could try downloading Google Chrome or firefox, as you said youself, might be the sercuity settings in internet explorer that blocks it.

      Eles you could try disableing your antivirus program just a split secound while depositing, you got AVG. avast? or something like that?
    • Marian21x
      Marian21x
      Silver
      Joined: 20.01.2010 Posts: 36
      Hello

      Originally posted by Holdemfreakie
      you could try downloading Google Chrome or firefox, as you said youself, might be the sercuity settings in internet explorer that blocks it.
      There is one problem, their software is designed for IE only.

      I wrote in live chat with support, I gave them some technical details of my comp, hope they can find it out, because I am not the only one having this kind of problems.

      I used to deposit my sisters comp, and it worked without any problems ?(