Possibly forgot postgreSQL password...fix?

    • deezer79
      deezer79
      Silver
      Joined: 13.06.2011 Posts: 191
      Am trying to get Elephant to run but postgreSQL is giving me troubles. There's a possibility that I tried installing this when I first trial ran Poker Tracker a while back and I can't remember my password. Can't remember the program TBH. Have googled around a bit and found some advice on forums, apparently you can change the .conf file to open as "trust" rather than using a password. Downloaded the first text editor I could find, gave it a go but it's saying I don't have sufficient rights to save changes in the file. Anyone know a fix? The editor I'm using is Editpad Lite, perhaps there is a better one? Way over my head with this :-(.
  • 10 replies
    • netsrak
      netsrak
      Gold
      Joined: 11.03.2006 Posts: 36,820
      PT uses dbpass as standard password.

      For the rights problem:
      you need to edit a copy of the file and move this back.
      You can for example copy the file to the desktop, open and change this file in a text editor like notepad.
      Create a backup copy of the original file and move the copy back to the original folder.
    • deezer79
      deezer79
      Silver
      Joined: 13.06.2011 Posts: 191
      dbpass is not working and I got around the rights issue by doing what you said. It's still asking for a password tho and clicking "next" in set up wizard tells me it needs the password. What am I missing here??
    • netsrak
      netsrak
      Gold
      Joined: 11.03.2006 Posts: 36,820
      I think the easiest is if you uninstall postgresql again and delete the postgres user with the password you can't remember.
      To do this open a command box with administrator rights (right mouse click, run as administrator) and enter:

      net user postgres /delete

      After successful completion you can assign a new password during the postgresql installation
    • deezer79
      deezer79
      Silver
      Joined: 13.06.2011 Posts: 191
      Have been trying this but I don't think it's working. I have no been given the choice of a username but while installing and uninstalling a couple of different versions I found a default password. This seems to be working but while setting up there's no username being assigned.

      The command prompt says that the command you gave me has worked but on re-installation, postgreSQL isn't giving me the option of setting up a new user - just asks for the password. I type in the default password an earlier installation suggested and it's installed.

      Don't know if a user has even been configured yet. How can I create a new user?
    • netsrak
      netsrak
      Gold
      Joined: 11.03.2006 Posts: 36,820
      The user is always postgres, its just the password that you can change.
      So i think everything is ok now.
    • deezer79
      deezer79
      Silver
      Joined: 13.06.2011 Posts: 191
      Now I have put postgres as username and svcPASS83 (seems to be a default) and am getting this error message:

      "Connection to database server lost!

      Further Informations:

      Failed to establish a connection to '127.01.0.1'."

      Thanks for your help so far netsrak.
    • netsrak
      netsrak
      Gold
      Joined: 11.03.2006 Posts: 36,820
      Is the postgresql service running? Check this in the windows services.

      can you connect via pgadmin?
    • deezer79
      deezer79
      Silver
      Joined: 13.06.2011 Posts: 191
      When I open Elephant and get to the error message stated above, postgrSQL isn't running in Windows. I can open pgAdmin III but there doesn't appear to be much happening. Made a screen grab of it but seems like you can't post it on here.

      I guess all that's on the properties listed on the server that may be useful are:
      -Host name "local host"
      -Port "5432"
      -Username "postgres"
      -Connected? No.

      When I try to connect on the settings set there I get this error message:

      "could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "localhost" (::1) and accepting TCP/IP connections on port 5432? could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "localhost" (127.0.0.1) and accepting TCP/IP connections on port 5432?"

      This make any sense to you?
    • netsrak
      netsrak
      Gold
      Joined: 11.03.2006 Posts: 36,820
      Go to windows control panel -> administration -> services.
      There you should see a postgresql service. If this service is not running something is wrong.

      I can only link you to the Holdemmanager FAQ for Postgresql: http://faq.holdemmanager.com/questions/91/Can%27t+Connect+%7B47%7D+Failed+to+Start+PostgreSQL+

      I have no experience with Elephant postgresql problems but as long as the service is not running.....
    • deezer79
      deezer79
      Silver
      Joined: 13.06.2011 Posts: 191
      Am on Windows 7 and looked in Administrative Tool under System and Security, no sign of postgresql in there. Will work through the link that you've attached and see where that gets me. Says most probs are caused by antivirus but states the one I have has no known issues with postgresql, might be worth uninstalling. Keep you updated. Thanks again.