Bought HM2 and ...

    • kiromanAAKK
      kiromanAAKK
      Bronze
      Joined: 08.10.2009 Posts: 4,022
      I bought HM2 this morning the money has gone out my bank account so the payment has been made but I still don't have the license code and so I cannot open HM2 as the trial has expired.

      I tried to contact their support but at moment still any sign of anything from their side. Is that normal?

      Usually when I buy anything I got what I payed for; is it works different for HM stuff?

      Any1 got any idea? Is it normal or I should do something?

      TY :)
  • 6 replies
    • Solidius
      Solidius
      Bronze
      Joined: 27.12.2010 Posts: 209
      Well, when i bought HM1, i waited 1-2 days and then they gave me the license code via e-mail. You'll get yours, just be patient.
    • kiromanAAKK
      kiromanAAKK
      Bronze
      Joined: 08.10.2009 Posts: 4,022
      Thanks mate, just enquire in case I need do any thing and also to verify if the timing is fine as sometime I miss thing out due my incompetence with those matters! :)
    • scscpoker
      scscpoker
      Bronze
      Joined: 29.06.2010 Posts: 121
      How long did you wait? Their support are still just people and not every person in support can instantly go view "all bank logs" and solve this problem in few hours.
    • hackbinder
      hackbinder
      Bronze
      Joined: 15.05.2009 Posts: 618
      Maybe your payment got flagged as suspicious... Mine did, twice! No worries though, HEM support is usually very quick...
    • netsrak
      netsrak
      Gold
      Joined: 11.03.2006 Posts: 36,820
      It can take a little bit longer over the weekend. And please check your spam folder too.
    • kiromanAAKK
      kiromanAAKK
      Bronze
      Joined: 08.10.2009 Posts: 4,022
      Originally posted by hackbinder
      Maybe your payment got flagged as suspicious... Mine did, twice! No worries though, HEM support is usually very quick...
      This!

      That's why I have opened this thread as I felt straight way that was something wrong!

      I even lost a bit yesterday (I suppose I was a bit tired anyway after all due all the hours of hard work) as the only thing I want avoid is just happened!

      This morning I received an email with the license code plus as I opened the HM2 to register the new license it was already there.

      I must say, those guys are very exellent people and deal with all the matter in a very good, great professional way (I was send a screaming bitch like me to f.o. :D ).

      Anyway, despite the cause and other about, I got the thing sort out in no time and I want thanks you guys for the attention and help (very appreciate ;) ) :heart: