Problem with postgreSQL

    • ozzy31
      ozzy31
      Bronze
      Joined: 06.01.2011 Posts: 15
      Hi!
      I just installed the poker tracker 4 trial and when i start it up i get a window that says "configure postgreSQL server".
      The server, port, database user and password are already filled but when I press connect it says: "Unable to connect to this database. Please check the configuration".
      Previously i have had the elephant for a while but I didn't really use it and my hm2 trial just ended. I would really like to see if i like poker tracker better but it's hard to do that if it isn't working so hopefully you can help me...
  • 5 replies
    • VorpalF2F
      VorpalF2F
      Super Moderator
      Super Moderator
      Joined: 02.09.2010 Posts: 8,910
      Hi, ozzy31

      Do you remember the password from when you had elephant?

      If so, you'll need it to connect.

      If not, there are ways to reset it.

      I suggest though, that you get PT4's customer support involved.

      It may be that your old PostgreSQL version is not the one the PT4 will want.

      Best regards,
      --BM
    • ozzy31
      ozzy31
      Bronze
      Joined: 06.01.2011 Posts: 15
      No I don't remember the password but i think there was a certain password that was suggested for everyone to use when installing it. My postgreSQL version seems to be 8.3.
    • VorpalF2F
      VorpalF2F
      Super Moderator
      Super Moderator
      Joined: 02.09.2010 Posts: 8,910
      8.3 is no longer supported by PostreSQL

      If you used the recommended password, try:
      elephant

      Even so, I still suggest that you contact PT4 support.

      They will have experience dealing with similar situations, and will likely have a list of steps that will solve your problem directly without a lot of fuss.

      Regards,
      --VS
    • PokerTracker
      PokerTracker
      Gold
      Joined: 07.06.2011 Posts: 643
      If you do not remember the password, you have two options.

      1) Get the correct password and user name, then enter it into PokerTracker 4. PokerStrategy's support and community may be able to help unless you entered in a non-standard user/password combination for Elephant

      2) Manually uninstall PostgreSQL 8.3 along with the associated user account, then install Postgres 9.0, our currently recommended version if you are manually installing. Do not install 9.1, 9.2, or 9.3 - these versions are not designed for desktop optimisation, we do not support them due to this reason, the most recent version we support is 9.0. If you have at least 4 Gigs of ram and a 64 Bit OS then we recommend installing the 64 Bit version of 9.0. We recomend that you backup your old data first as a precaution before uninstalling 8.3. For guidance please consult with these two guides -

      Uninstalling 8.3 & removing the PostgreSQL Service Account - https://www.pokertracker.com/guides/PT4/databases/how-to-uninstallreinstall-postgresql-83-windows

      Manually installing PostgreSQL 9.0 - https://www.pokertracker.com/guides/PT4/databases/how-to-uninstallmanually-install-postgresql-90-windows

      - TT
    • VorpalF2F
      VorpalF2F
      Super Moderator
      Super Moderator
      Joined: 02.09.2010 Posts: 8,910
      Thanks,
      I knew that you would have the answers :D

      --VS