icm trainer installation issue

    • altkiki
      altkiki
      Bronze
      Joined: 03.09.2009 Posts: 82
      hello there,

      this might sound silly, but i'm stuck with the installation of the icm trainer. i click on the setup it starts extracting file and then it gives me this message



      so if i hit no, the installation stops, if i hit yes it takes me to the .net framework page where i can download the latest version (wich is 4.0). the thing is that i allready have .net framework 4.0 installed. so i won't download and install it again.

      so i have no ideea what now. does this program really need .netframework 2.0 only? it can't work with 4.0? really?

      how could i install it skiping the .net framework step?
      pls help

      thanks
  • 3 replies
    • altkiki
      altkiki
      Bronze
      Joined: 03.09.2009 Posts: 82
      well, in the end i just installed 2.0 version as well, although it didn't seam to logical to me but i did it anyway, and it was the only way it worked. so with the 4.0 version allready installed i also installed .net framework 2.0 in order to be able to istall icm trainer.

      thanks guys :p
    • VorpalF2F
      VorpalF2F
      Super Moderator
      Super Moderator
      Joined: 02.09.2010 Posts: 9,508
      Surprisingly, newer .NET framework versions do not replace earlier ones, they exist separately.

      So v4.0 contains things that aren't in 2.0 -- and possibly vice-versa.

      If you're interested there is a whole whack -- perhaps even a whack and a half -- of information here:
      http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

      I've used the tool he describes at work to fix broken .Net installations, and I used it once to verify that my home .Net framework was working correctly when one of the poker sites was insisting I re-install it.

      Enjoy...
      --VS
    • altkiki
      altkiki
      Bronze
      Joined: 03.09.2009 Posts: 82
      thanks, i assumed 4.0 would be better than 2.0 and the new version will somehow include the old one