Can't connect to tables

    • NezNanec
      NezNanec
      Bronze
      Joined: 15.03.2011 Posts: 85
      So this is what happened

      My initial deposit onto betfred was through skrill(moneybookers), and then I decided to deposit through my credit card aswell (in order to be able to withdraw funds directly onto my credit card). A couple of minutes after the deposit was made, my account was locked and submitted to a random security check. They wanted pictures of my documents, credit card, a screenshot of my moneybookers profile utility bills etc.

      Allready used to this process I provided what was needed and a couple of hours later they told me everything works out and that my account has been unlocked. So naturally I tried to log in and my account was still locked. I contacted support again and then apologized, and told me my account is really uncloked now, so I tried logging in and it worked.

      But now every time I try to join a table (speed poker, normal NL Holdem, STNG, Regular tournaments) a blank table opens with no buy in options and just times out after a while. I allready contacted support about this and they told me they'd contact Ipoker network (supposedly the problem is not at their end). That all happened on friday.

      I'm still not able to play today, and received no additional info from betfred.

      Anyone else has the same problem? Any suggestion what I should do? Sucks to lose a whole weekend of grinding for this...
  • 3 replies
    • Lazza61
      Lazza61
      Headadmin
      Headadmin
      Joined: 23.03.2011 Posts: 9,900
      Hey NezNanec,

      Unfortunately I don't think we can help you. I can only suggest:

      1) Uninstall and reinstall the client (You've probably already done this).
      2) Stay in contact with Betfred support.

      I hope you can get it fixed soon.

      Keep us updated

      Laz
    • NezNanec
      NezNanec
      Bronze
      Joined: 15.03.2011 Posts: 85
      Yeah, I allready reinstalled tried running as administrator and whatnot, nothing seems to work.

      Talked to support today, they told me standard response time from iPoker network is 30 days. So I just decided to take my 25€ elsewhere.

      Sucks to be me though, my other poker accounts aren't tracked through this site so I won't be getting any strategy points.

      Thans for trying anyway :f_grin:
    • parke
      parke
      Bronze
      Joined: 26.06.2009 Posts: 32
      i have same problems to