Solution for: "failed to establish a connection to '127.0.0.1' "

    • batmanbg
      batmanbg
      Bronze
      Joined: 16.07.2008 Posts: 282
      I had the same problem when I tried to install PokerStrategy Elephant. Now i will show you how i fixed the problem.

      First step: Uninstall PostgreSQL

      > 1. Open Start menu > Control Panel > Add or Remove Programs and uninstall PostgreSQL
      > 2. Open C:\Program Files\ and delete PostgreSQL folder
      > 3. Open C:\Documents and Settings\ and delete the user created by PostgresSQL - "postgres" by default
      > 4. Delete postgresql from Application data

      - If your menu is classic path will be Start menu > Settings > Control Panel > Add or Remove Programs
      - If you can't find how to delete the user created by PostgreSQL write C:\Documents and Settings\ in your browser or My Computer there are "All users" "Your computer name" and "postgresql" - by default
      - If you can't find Application data write C:\Documents and Settings\YOUR COMPUTER NAME\Application Data in your browser or My Computer


      Second step: Install PostgreSQL

      > 1. Open C:\Program Files\PokerStrategy\PokerStrategy Elephant and find postgresql-8.3 (not postgresql-8.3-int) or directly write C:\Program Files\PokerStrategy\PokerStrategy Elephant\postgresql-8.3.msi in My Computer/Your browser.
      > 2. Choose English > Start > Next > Next > Next
      > 3. Service configuration:
      - Service name: PostgreSQL Database Server 8.3
      - Accout name: postgress (make it different from postgres with one s)
      - Account domain: Leave account name like is by default ( account domain = your computer name )
      - Choose account password and verify it then click Next
      > 4. Click yes to create the new account who will be used from elephant.
      > 5. In initialise database cluster change superuser name from postgres to postgress, write your password and then click Next and Finish


      Third step: Enter your new username

      Here you only have to write your new username "postgress" and your password

      If you see "Database was successfully created and is ready for usage" everything might be okay.

      If this works for you leave a comment and sorry for my bad english

      If you still have problems feel free to contact me in skype: stanimirmihov
  • 127 replies