elephant db optimize and "failed to connect to database"

    • TrifePT
      TrifePT
      Bronze
      Joined: 07.12.2008 Posts: 3
      Hi!
      I've optimized my database yesterday for the first time.
      After that i'm no longer able to connect to the postgresql database.

      I've tried everything:
      1) stop/start the service
      2) complete uninstall following every instruction available
      3) uninstalling firewall/AV (ESET/NOD)
      4) disabling windows defender
      5) deleting created users/folders/application data
      6) deleting associated registry entries
      5) reinstalling postgresql/poker elephant and even newer version of postgresql

      I still can't connect.
      The strange part is that the service is running fine and still i just can't "establish a connection to 127.0.0.1!.

      The install doesn't complete successfully as you can see below:
      http://yfrog.com/07erroqjgj
      http://yfrog.com/0lerro2tqej

      The reason that it doesn't complete without errors is the same that afterward elephant can't create a new database.

      Can anyone help me with this?
  • 5 replies
    • 6Wishmaster6
      6Wishmaster6
      Black
      Joined: 16.01.2005 Posts: 3,807
      Since you really semm to have done everything possible, the only thing i can think of, is that you deleted something neccessary on the way to try to solve the problem.
      So since I have no new tip for you, I would think about a new windows installation...
    • TrifePT
      TrifePT
      Bronze
      Joined: 07.12.2008 Posts: 3
      It's the last resort option but i'm still willing to do that just for elephant's sake :D

      Just two questions Wishmaster:
      1) Postgresql and Elephant are Windows 7 compatible?
      2) Can i request a new license? (i have a pc and a laptop and the license i requested for the pc was never used since the DB was broken :( )

      Thx!
    • TrifePT
      TrifePT
      Bronze
      Joined: 07.12.2008 Posts: 3
      I manage to fix it using a tip I found somewhere.

      The problem was a vista update by microsoft that messed with the hosts file.

      You just have to edit the hosts file in c:\windows\system32\drivers\etc with notepad and insert one line:

      127.0.0.1 localhost

      Nice to start using elephant (full) in my 22''.
    • 6Wishmaster6
      6Wishmaster6
      Black
      Joined: 16.01.2005 Posts: 3,807
      Nice to hear that!

      I do not know if postgres works with windows7. Please take a look at the officially postgre Froum. I guess it will work, but better take a look if you have to do anything "special" to get it working.

      If you need a new licence please contact our support through our ticket system. They will arange something for you!
    • fowler6
      fowler6
      Bronze
      Joined: 30.12.2008 Posts: 3
      hey mate. can u tell me exactly how you did that?

      mines broken too and it says that the particular host file you have pointed to is actually a sample. Howd u fix yours?