Zum Forum springen
[HEM1] PostgreSQL D...
 
Benachrichtigungen
Alles löschen

[HEM1] PostgreSQL Dienst lässt sich nicht mehr starten

6 Beiträge
2 Benutzer
0 Reactions
239 Ansichten
MRSuited
Beigetreten: 31.07.2006
Oldschool Grinder

Hallo zusammen,

hatte ein connect Problem mit PostgreSQL wie auch schon in anderen Threads beschrieben. Hintergrund hiervon war wohl, dass ich gestern, weil sich das aufgehangen hat, die PostgreSQL Prozesse im Taskmanager beendet habe, danach lief mein Rechner auch wieder. Ich habe auch schon die verschiedenen Tipps (Dienst auf lokal umstellen und selbst starten---Fehlermeldung und auch versucht die postmaster.pid löschen, die es aber bei mir nicht gibt, es gibt nur eine postmaster.opts). Habe auch schon neu installiert, aber der Dienst startet nicht mehr.
Hat jemand noch einen Vorschlag? Laut Ereignisprotokoll wartet der Dienst auf den Start des Servers?! Ich bin leider kein Computerjunkie...wäre für jede Hilfe dankbar!

VG


Antwort
Zitat
5 Antworten
MRSuited Themenstarter
MRSuited
Beigetreten: 31.07.2006
Oldschool Grinder

Ich habe über die Tools von PostgreSQL noch versucht, den Server zu starten, hier kommt folgende Meldung:
postgresql-8.4 - PostgreSQL Server 8.4 konnte nicht gestartet werden.
Der Dienst hat keinen Fehler gemeldet.
Sie erhalten weitere Hilfe, wenn Sie NET HELMPMSG 3534 eingeben.
The start command returned an error 2


Antwort
Zitat
netsrak
Beigetreten: 11.03.2006
Elite Grinder

Hast du bei der Neuinstallation das vorhandene data Verzeichnis übernommen (Cluster) oder ein neues erstellt?
Evtl. ist da was fehlerhaft und es geht nur mit einem neuen data Verzeichnis.


Antwort
Zitat
MRSuited Themenstarter
MRSuited
Beigetreten: 31.07.2006
Oldschool Grinder

Ich habe das vorhandene Data Verzeichnis übernommen, ich versuche es dann mal mit einem neuen. Was mache ich mit dem alten, kann ich das einfach händisch löschen?

VG und danke


Antwort
Zitat
MRSuited Themenstarter
MRSuited
Beigetreten: 31.07.2006
Oldschool Grinder

Hi,

so, diesmal hats geklappt, die Dienste laufen auch wieder, ich musste jetzt eine neue DB erstellen und importiere dann mal die nächsten 20 Stunden. Danke für Deine Hilfe.

VG


Antwort
Zitat
netsrak
Beigetreten: 11.03.2006
Elite Grinder

Wenn alles läuft kannst du das alte data Verzeichnis löschen


Antwort
Zitat
Teilen: