Zum Forum springen
[DONE] Elephant Zwa...
 
Benachrichtigungen
Alles löschen

[Geschlossen] [DONE] Elephant Zwangsupdate

16 Beiträge
2 Benutzer
0 Reactions
913 Ansichten
duffy
Beigetreten: 31.07.2006
PokerStrategist

Hi,

wenn ich den Elephant starte bekomme ich die Meldung "Version expired". Der Elephant startet gar nicht mehr!

Daraufhin habe ich mir die aktuelle Version 1.02 heruntergeladen und versucht diese zu installieren. Dabei soll zwangsweise die Datenbank exportiert und neu eingelesen werden (irgendwas mit "Versionskonflikt") Leider ist auf der Festplatte nicht mehr genug Platz für die exportierten Daten.

Wie kann ich die Datenbank manuell auf ein anderes Laufwerk exportieren und nach dem Elephant-Update manuell wieder einlesen? Aus dem Elephant geht's nicht, weil der nicht mehr startet, über das PostgreSQL-Menü habe ich nichts gefunden.

Gruß
Duffy


15 Antworten
mrk1988
Beigetreten: 05.02.2007
PokerStrategist

Hallo duffy,

das könnte jetzt etwas komplizierter werden.

Am besten gehst du folgendermaßen vor:

Du öffnest pgAdmin (Download, falls nicht mitinstalliert.), und verbindest dich erstmal zum Datenbank Dienst.

Das ganze sollte jetzt ungefähr so aussehen:

Jetzt wählst du deine Datenbank aus, rechtsklickst auf den Eintrag und wählst Backup. Du wählst noch einen Dateinamen aus und speicherst das ganze. Zur Sicherheit kannst du auch den gesamten PostgreSQL Ordner mitkopieren. Das Backup und den Ordner musst du dann natürlich schon auf die andere Festplatte kopieren.

Merke dir den exakten Datenbanknamen und dann kannst du mit pgAdmin die Datenbank leeren indem du das Menü mit dem Rechtsklick öffnest und "Löschen" wählst.

Speichere zur Sicherheit vorher auch noch deine originale Handhistories, falls du sie noch hast.

Du kannst jetzt die aktuellste Version des PokerStrategy.com Elephants installieren (0.105). Den Download findest du hier: http://elephant.pokerstrategy.com

Ist alles erledigt, legst du über den PokerStrategy.com Elephant eine neue Datenbank an, die genau so heißt wie die, die du gelöscht hast.
Über pgAdmin spielst du das Backup bei geschlossenem PokerStrategy.com Elephant wieder ein oder importierst die originalen Handhistories einfach wieder.

Solltest du bei einem der Schritte fragen haben, stell sie bitte rechtzeitig. ;)


duffy Themenstarter
duffy
Beigetreten: 31.07.2006
PokerStrategist

für das Backup ist im pgAdmin standardmäßig die Option "Blobs" angewählt

muss ich von den anderen dreien "Mit OIDs", "Insert-Kommandos", "$-Quoting abschalten"

auch etwas auswählen?


mrk1988
Beigetreten: 05.02.2007
PokerStrategist

Das Backup ist mit diesen Einstellungen korrekt. Kopiere aber zur Sicherheit auch noch den postgreSQL Ordner mit (z.B. C:\Programme\postgreSQL)
Auch nochmal der Hinweis auf die originalen Handhistories.


duffy Themenstarter
duffy
Beigetreten: 31.07.2006
PokerStrategist

Die Handhistories habe ich nur noch teilweise, sonst wäre es ja einfacher.

und wozu den PostgreSQL-Ordner kopieren? Um bei Problemen als Fallback wieder auf die original-Datenbank zugreifen zu können?

Die Sicherung über pgAdmin und den Update des Elephants habe ich jetzt gemacht. Außerdem im Elephant die DB wieder angelegt und den Elephant dann beendet.

Beim Wiederherstellen der Sicherung in pgAdmin habe ich dann eine Menge Fehler bekommen ... ich vermute dass ich dort "nur Daten" anklicken muss? (da die DB ja vom Elephant bereits wieder erstellt wurde)


mrk1988
Beigetreten: 05.02.2007
PokerStrategist

Die Verteilung der Haken in den Optionen sollte wie folgt aussehen:

Erfolgreich übernommen wurde das Backup wenn du als Error bzw. Fehlercode "0" erhältst.

Startest du danach den PokerStrategy.com Elephant sollte es im Grunde wie von Beginn an aussehen und du solltest keinen Unterschied zu vorher merken.


duffy Themenstarter
duffy
Beigetreten: 31.07.2006
PokerStrategist

Funktioniert wie gesagt nicht, beim Restore treten leider 197 Fehler auf ?(

C:\Program Files\pgAdmin III\1.8\pg_restore.exe -h localhost -p 5432 -U elephant -d elephantdb2 -v "C:\Documents and Settings\Gandalf\Desktop\Backup_elephantdb2.backup"
pg_restore: connecting to database for restore
pg_restore: creating SCHEMA public
pg_restore: creating COMMENT SCHEMA public
pg_restore: creating PROCEDURAL LANGUAGE plpgsql
pg_restore: [archiver (db)] Error while PROCESSING TOC:
pg_restore: [archiver (db)] Error from TOC entry 470; 2612 16386 PROCEDURAL LANGUAGE plpgsql elephant
pg_restore: [archiver (db)] could not execute query: ERROR:  language "plpgsql" already exists
    Command was: 
CREATE PROCEDURAL LANGUAGE plpgsql;
pg_restore: creating TYPE action
pg_restore: [archiver (db)] Error from TOC entry 343; 1247 97092 TYPE action Poker
pg_restore: [archiver (db)] could not execute query: ERROR:  type "action" already exists
    Command was: CREATE TYPE action AS ENUM (
    'unknown',
    'fold',
    'check',
    'call',
    'bet',
    'raise',
    'allincall',
  ...
pg_restore: creating TYPE blindserror
pg_restore: [archiver (db)] Error from TOC entry 341; 1247 97086 TYPE blindserror Poker
pg_restore: [archiver (db)] could not execute query: ERROR:  type "blindserror" already exists
    Command was: CREATE TYPE blindserror AS ENUM (
    'no',
    'sb',
    'bb',
    'bo'
);
pg_restore: creating TYPE importstatus
pg_restore: [archiver (db)] Error from TOC entry 327; 1247 96838 TYPE importstatus Poker
pg_restore: [archiver (db)] could not execute query: ERROR:  type "importstatus" already exists
    Command was: CREATE TYPE importstatus AS ENUM (
    'false',
    'processing',
    'true'
);
pg_restore: creating TYPE limittype
pg_restore: [archiver (db)] Error from TOC entry 329; 1247 96843 TYPE limittype Poker
pg_restore: [archiver (db)] could not execute query: ERROR:  type "limittype" already exists
    Command was: CREATE TYPE limittype AS ENUM (
    'FL',
    'NL',
    'PL'
);
pg_restore: creating TYPE moneytype
pg_restore: [archiver (db)] Error from TOC entry 345; 1247 97115 TYPE moneytype Poker
pg_restore: [archiver (db)] could not execute query: ERROR:  type "moneytype" already exists
    Command was: CREATE TYPE moneytype AS ENUM (
    'Real Money',
    'Play Money'
);
pg_restore: creating TYPE valuta
pg_restore: [archiver (db)] Error from TOC entry 347; 1247 97119 TYPE valuta Poker
pg_restore: [archiver (db)] could not execute query: ERROR:  type "valuta" already exists
    Command was: CREATE TYPE valuta AS ENUM (
    'CHP',
    'USD'
);

[...]

pg_restore: setting owner and privileges for INDEX quiz_game_id
pg_restore: setting owner and privileges for INDEX quiz_language
pg_restore: setting owner and privileges for INDEX realplayer_name
pg_restore: setting owner and privileges for INDEX shc_combined_key
pg_restore: setting owner and privileges for INDEX tournament_datestart
pg_restore: setting owner and privileges for INDEX tourneypokerroomindex
pg_restore: setting owner and privileges for INDEX tourneytimeoffirsthandindex
pg_restore: setting owner and privileges for INDEX tourneytourneyidindex
pg_restore: setting owner and privileges for INDEX win_game_id
pg_restore: setting owner and privileges for TRIGGER deflag_archive
pg_restore: setting owner and privileges for TRIGGER insert_into_playercache
pg_restore: setting owner and privileges for TRIGGER insert_or_skip
pg_restore: setting owner and privileges for TRIGGER unreviewed_delete
pg_restore: setting owner and privileges for TRIGGER unreviewed_insert
pg_restore: setting owner and privileges for TRIGGER unreviewed_update
WARNING: errors ignored on restore: 197

duffy Themenstarter
duffy
Beigetreten: 31.07.2006
PokerStrategist

die Option "clean before Restore" (aus Deinem Screenshot) gibt's in meinem pgAdmin übrigens nicht!


mrk1988
Beigetreten: 05.02.2007
PokerStrategist

Ich sehe auch gerade, dass ich eine andere Version nutze als die, die ich dir verlinkt habe. Hast du das Wiederherstellen mit "nur Daten" bereits versucht?


duffy Themenstarter
duffy
Beigetreten: 31.07.2006
PokerStrategist

Ich habe jetzt einfach eine neue leere Datenbank erstellt.

Mir reichen 1,5 Tage für Datenbank-Maintenance ... finde diesen "Zwangsupdate" eher suboptimal gelöst

Gruß
Duffy


mrk1988
Beigetreten: 05.02.2007
PokerStrategist

Das "Zwangsupdate" hat durchaus seine Berechtigung. Jemand der nicht durchgehend den Entwickler Blog liest, übersieht des öfteren ein kritisches Update, dass aktuelle Fehler behebt.

In deinem Fall ist das natürlich äußerst ungünstig mit einer vollen Festplatte passiert. Ich habe aber vorhin nochmal die Backup / Restore Funktion von der aktuellsten pgAdmin Version getestet und das ganze funktioniert noch einwandfrei mit meinen Datenbanken.

Wie verfährst du jetzt weiter?


duffy Themenstarter
duffy
Beigetreten: 31.07.2006
PokerStrategist

Eigentlich habe ich keine Lust mehr weiter Zeit zu investieren ...

Ich könnte das genze Prozedere allerdings nochmal starten, da ich meine komplette Poker-Software in einer VM installiert habe. (Deshalb ging mir da auch der Speicherplatz aus) Einen Snapshot vom original-Zustand gestern habe ich noch.

Das ganze ist jedoch recht aufwändig und der Ex- und Import dauert auch recht lange.

Was mir noch aufgefallen war: als ich die Elephant-Version aktualisiert hatte und im Elephant die Datenbank neu erstellt hatte, wurde mir bereits in einem Popup-Fenster eine Meldung angezeigt (sinngemäß) "Falsche Datenbank-Version, Aktualisierung nötig". Wie kann das sein?

Hast Du denn noch eine andere Version von dem pgAdmin-Tool?


duffy Themenstarter
duffy
Beigetreten: 31.07.2006
PokerStrategist

Hast Du aus den Meldungen im Fehler-Log oben eigentlich etwas erkennen können?


mrk1988
Beigetreten: 05.02.2007
PokerStrategist

Zu den Meldungen oben kann ich erstmal nichts sagen. Allerdings kann ich dir sagen, dass die erneute Meldung "Ihre Datenbank ist veraltet" ignoriert werden kann.

Ja, ich hatte noch mit einer älteren Version von pgAdmin gearbeitet.
Wenn du es mit der älteren ausprobieren willst, die Versionsnummer lautet: 1.10.0


duffy Themenstarter
duffy
Beigetreten: 31.07.2006
PokerStrategist

Werde ich mir mal überlegen ...
Vielen Dank für Deine schnelle und ausführliche Hilfe!

Thread kann geschlossen werden


mrk1988
Beigetreten: 05.02.2007
PokerStrategist

Okay, dann mach ich mal zu.


Teilen: