Elephant 0.49 instalation problem

    • Samo2
      Samo2
      Bronze
      Joined: 01.02.2008 Posts: 69
      Hi, I have problem with elephant instalation.

      I had one of the older versions installed. When I was preparing to install the new version, I first uninstalled postgres SQL, as it is writen at the top of this forum, and the old version of Elephant. I rebooted computer. Then I tried to install the new version and got the next message

      "Connection to database server lost!

      Further Informations:

      Failed to establish a connection to '127.0.0.1' "

      I have also noticed that Elephant didn't install a new Postgre database (I have removed the old one).

      What can I do?
  • 25 replies
    • Samo2
      Samo2
      Bronze
      Joined: 01.02.2008 Posts: 69
      Hi, again. After a lot of forum reading and few tries I've found a solution.It was realy a database problem.
      I don't know why, but after uninstaling PostgreSQL, as it is writen in important threads Deinstalling PostgreSQL correctly . I couldn't make Elephant to install PostgreSQL database, so I went to PT3 and installed it together with the PostgreSQL 8.3 database.

      Solution to the problem:
      1. first completly uninstal Elephant and existing PostgreSQL 8.3, as mentioned in important thread Deinstalling PostgreSQL correctly
      2. reboot computer
      3. go to PT3 site and download PT3 (full version with PostgreSQL 8.3). They have 30 days trial period
      4. install PT3 and the PostgreSQL 8.3 database. When database is installed it will show you a screen with it's connection details. Be shure to write down service name with password and database username with password. You'll need them later
      5. now install Elephant
      6. start Elephant. It will tell you that you need to create a database. Click OK and when it prompts you about the Settings, write "postgres" as the username, and the password that you wrote down in point 4. Under "Enter the database name" just click on a magnification glass icon. It should pop-up the small window with PT3 DB in the list. Select it and confirm (OK).
      7. Sit back and wait until database is created.
      8. If you go to the elephant main menu (after everything is done) and select Setting - Database and repeat steps in point 6, you'll see that you now have two databases, PT3 DB and elephantdb

      I hope this will help anybody.
    • ddasd
      ddasd
      Bronze
      Joined: 07.11.2006 Posts: 114


      i have this error that pw isnt right for the user

      i installed PT3 and left defoult username and password and everything works there just fine

      but it doesnt works with pE
    • ciRith
      ciRith
      Bronze
      Joined: 25.03.2005 Posts: 18,556
      I have no clue but I think that you can't name the database 'postgres'.
    • galam
      galam
      Bronze
      Joined: 06.03.2005 Posts: 11,136
      Jep, exactly thats the problem. The database postgres is existing after installing postgreSQL for administrational purposes. Please try the hole thing with an other database name.

      Greets Sebastian
    • Samo2
      Samo2
      Bronze
      Joined: 01.02.2008 Posts: 69
      Galam, I think you are right. Because when I installed PT3, I had just the database with "PT3 DB" name. You need to click on a magnification glass to the right of the database name and it shows wich databases are already created.

      DDasd, check point 6 of my "procedure" and try to stick to it.
    • DeKuip
      DeKuip
      Bronze
      Joined: 07.03.2008 Posts: 10,966
      Step 1 t/m 5 worked great.
      But when I try to execute step 6, Elephant simply freezes from the moment I push the "ok" button :(

      Does anyone have any idea what to do?
    • DeKuip
      DeKuip
      Bronze
      Joined: 07.03.2008 Posts: 10,966
      Could someone help me out here?
      The above problem is still not solved.
      Besides that, I can't properly unregister postgresql.
      When I think it's unregistered and I try to make a new database, it says "name arleady exists", but when I click on "Ok" I can't try another one, it just closes down.

      It's a complete mess and it's starting to annoy me real bad right now.
      I haven't seen anything useful from this program yet. While it was running it was simply crap, but now I can't even get it running anymore.

      It would be appreciated if someone could help out...

      Edit: I've uninstalled Elephant, PokerTracker and postgresql now.

      It was all removed from my software list and I can't find anything postgres-related anymore.
      I never was able to find anything from step 3,4 and 5 as stated in this thread .
      So I suppose that's also gone.

      If somebody could please tell me what to do now!!
    • DeKuip
      DeKuip
      Bronze
      Joined: 07.03.2008 Posts: 10,966
      Problems solved!
    • Cardbender
      Cardbender
      Bronze
      Joined: 03.03.2008 Posts: 1,070
      thx samo, worked well
    • xponentx
      xponentx
      Bronze
      Joined: 10.02.2008 Posts: 341
      Hey DeKuip, how did you fix your issue? I have the same problem now, it freezez when I try to add the PS3 DB in Elephant.
    • vency
      vency
      Bronze
      Joined: 31.10.2007 Posts: 2
      yuo shouldn't do that, yuo just write ther elephantdb and it will works...

      at least it works for me...
    • DeKuip
      DeKuip
      Bronze
      Joined: 07.03.2008 Posts: 10,966
      Originally posted by xponentx
      Hey DeKuip, how did you fix your issue? I have the same problem now, it freezez when I try to add the PS3 DB in Elephant.
      I didn't fix it.
      One of the Dutch moderators fixed it for me. Something with "magic touch", holy crap...

      I've been looking at it for days, he just gives it a try and succeeds in installing it correctly.
      So I'm really sorry, but I just don't know how it happened.. :(
    • xponentx
      xponentx
      Bronze
      Joined: 10.02.2008 Posts: 341
      No worries, I have managed to sort it myself (quite a few times since my last post) using PGAdmin.
    • Braindmg
      Braindmg
      Bronze
      Joined: 30.12.2007 Posts: 31
      can someone tell me how did you fix that freezing problem?

      and this happened with elephant 0.58 whit windows XP
    • Fagin
      Fagin
      Bronze
      Joined: 06.05.2008 Posts: 544
      I have had the same problem today .... tried installing Elephant for the first time and got the message ...

      "Connection to database server lost!

      Further Informations:

      Failed to establish a connection to '127.0.0.1'

      I have looked at the solution given above with the suggestion of checking the postgre?? uninstallation thread ... checked that thread and did not understand the instructions ... I am not much good with computers and need things spelt out in an idiot-proof way.

      Don't want to install PT3 and fiddle about with creating more databases I won't be using and maybe having to uninstall them somehow later ... that seems overly complicated to me.

      Can anybody give me some simple instructions as to how to install Elephant (ones that work preferably) or how to sort out the above problem please??

      Thanks for your time
    • galam
      galam
      Bronze
      Joined: 06.03.2005 Posts: 11,136
      Hmm that error indicates that postgresql isnt working correctly. So i would recommend to do a manual installation using the setup file from the Elephant dir. Please write down the user/pws you entered because you need them later on.
    • Fagin
      Fagin
      Bronze
      Joined: 06.05.2008 Posts: 544
      Originally posted by galam
      Hmm that error indicates that postgresql isnt working correctly. So i would recommend to do a manual installation using the setup file from the Elephant dir. Please write down the user/pws you entered because you need them later on.
      Hi and thanks for your reply. I have uninstalled and reinstalled but get the same problem so uninstalled again. I have searched for postgresql since but not found it so guess it was uninstalled also.

      I would not know how to do a "manual installation" (sounds painfull lol). I tried to just get into Elephant and do something from there but it would not let me do anything without the db and kept giving the same error message.

      If you have any other ideas or could give me some fairly simple instructions on the "manual installation" that would be great thanks.
    • galam
      galam
      Bronze
      Joined: 06.03.2005 Posts: 11,136
      So go to the Elephant-dir. Theré you gonna find the setup of postgreSQL. Simple launch that setup and dont change anything. Please just note the user/pw you enter because you gonna need it later on. After that it should work.
    • thedahl
      thedahl
      Bronze
      Joined: 07.04.2008 Posts: 270
      Can anyone help me with the freezing problem? Please :)
    • 1
    • 2