Passer au forum
Problème PostgreSQL
 
Notifications
Retirer tout

[Fermé] Problème PostgreSQL

3 Messages
2 Utilisateurs
0 Réactions
492 Vues
Freddz
Inscrit : 16.03.2008
Oldschool Grinder

Voilà j'ai bien fouillé dans les topics, et essayer à peu près tout ce que j'ai lu, mais rien y fait, j'ai toujours le failed to establish a connection to '127.0.0.1.

Pendant l'installation de Postgre j'ai eut le droit à un message d'erreur qui est:
"Failed to connect to the database. Procedural languages files are installed but are not activated in any databases."

J'ai cliqué sur "ok" puis est venu ce message:
"could not connect to server. Connection refused (0x0000274D/10061)
Is the server running on host "127.0.0.1" and accepting TCP/IP connections on port 5432 ?"

J'ai cliqué sur "ok" puis est venu ce message:
"Failed to connect to the 'template1' database. Contrib files are installed but are not activated in any databases."
J'ai cliqué sur "ok" puis j'ai a nouveau eut le droit au 2ème message d'erreur que j'ai écrit au dessus puis en cliquant sur "ok", j'ai eut le droit à la fenêtre ou je doit cliqué sur "finish".

Postgre semble bien installé, mais ça m'intrigue quand même tout ces messages d'erreur. Et en plus j'arrive toujours pas à faire marcher Elephant.

Dans la manip' de ce thread: celui-là, vas-y clique
J'ai pas trouvé le truc dont on parle au 4ème point de la first step, j'ai pourtant fouillé un peu partout.

Enfin voilà si quelqu'un pouvait m'aider pour faire fonctionner l'Elephant, je suis preneur, parce que je galère depuis quelques heures, alors que je sui quand même pas une grosse branque en info.

Je suis sous Vista.


2 réponses

Essaye ce lien pour Postgres, c'est plutot bien expliqué.

Postgres

Sinon, le dossier Application Data est par defaut un dossier/fichier caché si j'ai bonne mémoire. Tu dois donc autoriser l'affichage de ce type de dossier/fichier pour le trouver.


Freddz Auteur du sujet
Freddz
Inscrit : 16.03.2008
Oldschool Grinder

Merci pour ta réponse. J'ai suivi ton guide étape par étape, mais ça fait exactement pareil, à part qu'avant j'installais pas "psqlODBC", j'ai encore eut les messages d'erreur pendant l'install et j'ai toujours le "failed to establish a connection to '127.0.0.1'".

J'ai essayer le truc de remplacer "localhost" par * dans le fichier .conf, mais j'ai pas eut plus de succès.

Edit: ok je viens de m'apercevoir que j'avais oublié de supprimer le # devant la ligne qui contient "localhost" et ca marche. Désolé d'avoir fait chercher pour un truc aussi con.

Pour ceux qui auraient un problème similaire, j'ai suivit le tut de yakari. Puis dans Program Files/PostgreSQL/8.3/data j'ai ouvert postgresql.conf avec le bloc-note, ensuite j'ai fait "remplacer":
#listen_addresses = 'localhost'
par:
listen_addresses = '*'

Voilà merci à toi Yakari.