Zum Forum springen
postgre install. cl...
 
Benachrichtigungen
Alles löschen

[Geschlossen] postgre install. cluster initialisation failed

7 Beiträge
3 Benutzer
0 Reactions
1,164 Ansichten
fishkopp
Beigetreten: 16.02.2008
Oldschool Grinder

hi
will mir hm zulegen nur leider bekomm ich postgresql nicht installiert.
hab win xp, vorher noch kein postgre auf diesem rechner gehabt.
zunächst wollte ich standard install machen hm 1 click installer, aber da installiert er esrst hm aber sobald es zur postgres installation kommt kam immer der fehler : an error occured on executing the microsoft vc++ runtime installer

also hab ich mir postgres 8.4.2-1 rutnergeladen, und mit dem command: postgresql-8.4.2-1-windows.exe --install_runtimes 0 gestartert und die installation hat dann auch gestartet.
es läuft durch aber am ende kommt der fehler:
Problem running post install step. installation may not be completed correctly. the database cluster initialisation failed.

so nun sitz ich hier rum google ständig und find keine lösung.
immer nur für vista nutzer dass sie admin rechte geben sollen.
kennt jemand den fehler und kann mir einen wink/tipp in die richtige richtung geben?


6 Antworten
netsrak
Beigetreten: 11.03.2006
Elite Grinder

XP Version? Service Pack 3 installiert, alle Windows Updates installiert?

Firewall / Virenscanner?

Sonst irgendwas an Anti Spyware / Adaware / Tune Utilities laufen?

Irgendwelche Standard Dienste deaktiviert?

Festplatte zu voll?

Du könntest auch mal Postgresql 8.3 versuchen. Auf manchen Systemen läuft das besser.


fishkopp Themenstarter
fishkopp
Beigetreten: 16.02.2008
Oldschool Grinder

ok, grad den sticky erst gelesen. sry wegen system info.
aber in der kurzen zeit bis zu deiner antwort hab ich weiter rumexperimentiert
also hab jetzt bitnami WAPPStack installiert.
lol ich hab halt echt keine ahnung, aber die installation hat funktioniert.
wenn ich das dann starte geh ich über den browser da reiN?!
ist das irgendein nachteil?
auf jedenfall läuft postgresql jetzt server steht anscheinend weil HM auch darauf zugreifen kann.

ist dann jetzt alles gut oder muss ich was besonderes beachten?

muss ich jetzt jedesmal im "browser" den server starten, oder kann das hM, muss ich server als beenden?

aber danke schonmal für dein schnelles reagieren.
mfg


fishkopp Themenstarter
fishkopp
Beigetreten: 16.02.2008
Oldschool Grinder

ach du schicker bist ja auch im anderen forum
ja das bin ich, also kannst dort dann closen, sry wusste nicht dass du in beiden foren bist.
sorry für "quasi doppelpost"
mfg


netsrak
Beigetreten: 11.03.2006
Elite Grinder

Ich weiß nicht was du mit Browserstart meinst, normalerweise ist Postgresql ein Windows Dienst (also in den Windows Diensten in der Systemsteuerung) der mit dem Rechnerstart gestartet wird.


fishkopp Themenstarter
fishkopp
Beigetreten: 16.02.2008
Oldschool Grinder

k sorry für fishausdruck :)
WAPPStack, hierzu gibt es dann keine software als benutzeroberfläche, sondern man "verwaltet" postgresql über den browser.
naja die installation von postgres hat halt nur so funktioniert.
hm scheint jetzt allerdings zu funktionieren.
also prinzipiell problem solved.
wollte nur wissen ob durch die installation mit wappstack irgendetwas anders ist.
mfg


edit: hat sich erledigt


Teilen: