Zum Forum springen
Ele will neue DB ei...
 
Benachrichtigungen
Alles löschen

[Geschlossen] Ele will neue DB einrichten

15 Beiträge
5 Benutzer
0 Reactions
436 Ansichten

Bei mir kam heute beim Starten die Meldung, eine neue Version der DB sei installiert und ein Patch nicht möglich, deshalb müsste eine neue DB erstellt werden. Bitte geben Sie Benutzername und Passwort an... Nach Klick auf OK die Fehlermeldung: Es konnte keine Verbindung zum Datenbankserver aufgebaut werden! Failed to establish a connection to '127.0.0.1'.

Und nun??? Bis gestern hats noch funktioniert. Meine Konfiguration: Windows XP, Elephant 0.67.


14 Antworten
mrk1988
Beigetreten: 05.02.2007
PokerStrategist

Guck mal ob der SQL Dienst läuft. Systemsteuerung -> Verwaltung -> Dienste -> PostgreSQL Server Dienst.

Falls er läuft, starte ihn mal neu.

Kannst du, sobald du aufgefordert wirst eine neue DB anzulegen deine alten richtigen Daten angeben und dann Ok klicken?

Kommt die Fehlermeldung auch wenn du auf das Lupen Symbol klickst?


_Anonymous_ Themenstarter
_Anonymous_

Dienst habe ich neu gestartet, ändert nichts.

Original von mrk1988
Kannst du, sobald du aufgefordert wirst eine neue DB anzulegen deine alten richtigen Daten angeben und dann Ok klicken?

Auch dann bleibt es bei dem Fehler.

Kommt die Fehlermeldung auch wenn du auf das Lupen Symbol klickst?

Ja.
Noch ne Idee? Danke schonmal für die Bemühungen!


mrk1988
Beigetreten: 05.02.2007
PokerStrategist

4. Go to C:\Program Files\PostgreSQL\8.x\data and delete the postmaster.pid file.

Klick dich bitte mal zum Installations Ordner von PostgreSQL standardmäßig unter:

C:\Programme\PostgreSQL\8.x\data und lösch dort mal die Datei "postmaster.pid".

Keine anderen Dateien, nur diese!

Starte danach mal den Dienst neu, (Systemsteuerung, Verwaltung, Dienste).

Klappts jetzt?

Hast du eine Firewall? Das kann mit ein Grund sein warum du dich nicht mehr zum Datenbank Dienst verbinden kannst. Überprüf mal ob die Firewall die Verbindung blockt.

lg


Torch
Beigetreten: 01.05.2006
PokerStrategist

hatts was gebracht?
hab nämlich dasselbe problem...


mrk1988
Beigetreten: 05.02.2007
PokerStrategist

Ansonsten arbeitet euch doch bitte mal durch folgenden Thread:

[Guide] Datenbank Probleme


_Anonymous_ Themenstarter
_Anonymous_

Original von mrk1988

Klick dich bitte mal zum Installations Ordner von PostgreSQL standardmäßig unter:

C:\Programme\PostgreSQL\8.x\data und lösch dort mal die Datei "postmaster.pid".

Keine anderen Dateien, nur diese!

Diese Datei existiert bei mir nicht. Es gibt nur eine "postmaster.opts".

Hast du eine Firewall? Das kann mit ein Grund sein warum du dich nicht mehr zum Datenbank Dienst verbinden kannst. Überprüf mal ob die Firewall die Verbindung blockt.
lg

Nur die XP-eigene, aber das Problem besteht weiterhin, wenn ich sie ausschalte. Daran liegts also auch nicht. Ich werd dann mal weitersuchen...


Hatte das gleiche Problem, nach löschen der .pid-Datei hat er die alte Datenbank wieder geladen.


mrk1988
Beigetreten: 05.02.2007
PokerStrategist

Original von Tirris
Hatte das gleiche Problem, nach löschen der .pid-Datei hat er die alte Datenbank wieder geladen.

Hm, dann hats zumindest dir schonmal geholfen ;)


_Anonymous_ Themenstarter
_Anonymous_

Ich weiß inzwischen, dass der Dienst bei mir gar nicht läuft, er lässt sich nicht starten. Gibt aber auch keine Fehlermeldung, warum nicht. Mit dem Troubleshooting aus der PostgrSQL Einführung kam ich auch noch nicht weiter, werde es wohl mal mit einer Neuinstallation versuchen müssen.


mrk1988
Beigetreten: 05.02.2007
PokerStrategist

Das ist wohl das beste, wenn sich der Dienst nichtmal mehr starten lässt. Zur Deinstallation würde ich dir empfehlen das hier zu lesen: How-To: Deinstallation von PostgreSQL


ich hab den datenbank dienst nue gestartet, die genannte datei gelöscht.
dann beim elephant bei neuer datenbank den namen der alten db und die log ins eingegeben und hat alles wunderbar geklappt :)


mrk1988
Beigetreten: 05.02.2007
PokerStrategist

Supi, freut mich =)


_Anonymous_ Themenstarter
_Anonymous_

Nach Neuinstallation von PostgreSQL läufts jetzt wieder. Komische Geschichte, naja. Danke für die Hilfe.


mrk1988
Beigetreten: 05.02.2007
PokerStrategist

Bitte. Hauptsache es funktioniert wieder =)


Teilen: